Newer posts are loading.
You are at the newest post.
Click here to check if anything new just came in.

February 21 2016

wrf
Reposted fromcreativestuff creativestuff

January 23 2014

Ein Podcast CDN!

So, jetzt habe ich das tatsächlich gebaut.

Nach einigem Hin- und Hergequatsche mit Toby vom Einschlafen Podcast bin ich dann mal nach Servern schnorren gegangen. Dank ein paar Sponsoren (mehr steht auf http://podseed.org/) ging das dann recht flott.

Aufgesetzt sind die Server mit Salt, eine neue Box ins CDN aufzunehmen ist tatsächlich eine Sache von 5-10 Minuten, wenn ein Debian-artiges OS aufgespielt ist. Der Content wird mit btsync synchron gehalten, auch das lief nach den ersten paar Tests stabil.

Überraschend finde ich die Lastverteilung per DNS Round-Robin. Wenn man sich den Trafficgraphen anschaut, ist die Verteilung ziemlich symmetrisch.

Alles in allem läuft das ganze sehr rund (von ein oder zwei Anfangsschwierigkeiten abgesehen). Jetzt nur noch eine anständige Statistik bauen..

October 21 2013

Ein Podcast Delivery Network

Mir schwirrt seit gestern abend schon die Idee eines Delivery Networks für Podcasts im Kopf rum. Die Mikrodilettanten hatten leichte Probleme, ihre Podcasts an den Hörer zu bringen, weil der Hoster wegen zuviel Bandbreitennutzung den Betrieb eingestellt hatte. Ähnliches ist dem Toby Baier wiederfahren, dessen VPS einfach den Traffic nicht mehr verkraftet hat.

Generell liest man von fast allen Podcastern, daß das ausliefern von Dateien immer zu Problemen führt. Hier scheint also etwas zu fehlen, um das Hosting von Podcasts wirklich einfach und zuverlässig zu machen.

Die Lösung wäre relativ einfach: Es gibt eine zentrale Stelle um Podcasts hochzuladen, danach werden die Mediendateien auf alle Knoten verteilt. Die Knoten wären günstige Server von beliebigen deutschen/europäischen Hostern. Die Basiskonfiguration erschlägt man per puppet oder ähnlichem. Lastverteilung über die Knoten macht man per DNS round-robin, das muß innerhalb von Europa noch nicht mal mit Globalem Loadbalancing erfolgen. Upload könnte per FTP erfolgen, direkt aus auphonic heraus. Dann muß man der Publisher Software nur noch beibiegen, wo externe Mediendateien zu finden sind.

Dazu dann noch eine Logfileauswertung, ein bisschen Überwachung und ein oder zwei fähige Admins.

Bleibt nur die Frage: Wie zieht man das ganze auf? Am sinnvollsten wäre ein eingetragener Verein, bei dem die Mitglieder sich an den Hosting Kosten beteiligen. Ach so, und Mitglieder bräuchte es auch noch. Gibt es da draußen Interesse?

Update:

Einige meinten, daß man doch auch Amazon S3 und Cloudfront nutzen könne. Ich hab das spaßeshalber mal mit ein paar Zahlen aus Tobys Podcasts durchgerechnet, die bei mir auf dem Server liegen. Alle Werte wurden völlig dilettantisch aus den access_logs ermittelt.

Zugriffe im September: 818375

Übertragenes Datenvolumen: etwa 1,5TB

Wenn man das jetzt bei Amazon einklimpert, möchten die etwa 180$ von einem haben. Davon kann man im Monat 7-8 Server mieten..

October 13 2012

wrf

November 23 2011

Juniper SRX und IPv6 mit tunnelbroker.net und dynamischer IP Adresse

Ich habe meinen Linux Router zu Hause gegen eine Juniper SRX100 getauscht. Und plötzlich war mein IPv6 weg. Der Linux Router hat das ganz brav per SIXXS und AICCU bereit gestellt, die Juniper kann kein AICCU. Gestern abend habe ich mich dann endlich mal rangesetzt und IPv6 und dyndns zu Hause wieder zum Laufen bekommen.

Jetzt erstmal als config-dump, später mehr Details.
Die passenden Skripte finden sich hier (Disclaimer: Scripte schamlos aus dem Juniper Forum geklaut und editiert, YMMV, you have been warned).

system {
    services {
        apply-macro dyndns-client1 {
            hostname yourhostname
            password yourpassword;
            type dyndns;
            username yourusername;
        }   
        apply-macro tunnelbroker-1 {
            password yourpassword;
            tunnelid yourtunnelid;
            username youruserid;
        }  
}

security {
    flow {
        tcp-mss {
	    all-tcp {
	        mss 1280;
	    }
        }
    }
}

interfaces {
   ip-0/0/0 {
        unit 0 {
            tunnel {
                source localip;
                destination tunnelbroker-ip;
                path-mtu-discovery;
            }   
            family inet6 {
                address youripv6address;
            }
        }
    }
   pp0 {
       unit 0 {
          family inet {
              filter {
	      	 input fix-v6v4-tunnel;
              } 
	  }
       }
   }
   vlan {
       unit 0 {
           family inet6 {
               address YOURIPV6NETWORK::1/64;
	   }
       }
   }
}

protocols {
    router-advertisement {
        interface vlan.0 {
            prefix YOURV6PREFIX;;
        }   
    }
}
event-options {
    policy dsl-up {
        events SYSTEM;
        attributes-match {
            SYSTEM.message matches "EVENT Add";
        }   
        then {
            event-script dyn-dns-update.xslt;
            event-script tunnelbroker-net.xslt;
            event-script update-tunnel.slax;
        }   
    }   
    event-script {
        file dyn-dns-update.xslt;
        file tunnelbroker-net.xslt;
        file update-tunnel.slax;
    }   
}
routing-options {
    rib inet6.0 {
        static {
            route ::/0 next-hop 2001:470:1f08:1e6c::1;
        }   
    }  
}
firewall {
    family inet {
        filter fix-v6v4-tunnel {
            term 1 {
                from {
                    destination-address {
                        216.66.80.26/32;
                    }
                    protocol 41;
                }
                then packet-mode;
            }
            term 2 {
                from {
                    source-address {
                        216.66.80.26/32;
                    }
                    protocol 41;
                }
                then packet-mode;
            }
            term 3 {
                then accept;
            }
        }
    }
}

September 14 2011

WPA/WPA2 auf Cisco Aironet

Ich habe mir teilweise bei Cisco den Browser fusselig gesucht und wenig dazu gefunden.

Daher hier mal eine kleine Zusammenfassung, wie man auf Ciscos Aironet Accesspoints WPA und WPA2 ohne externen Radius Server konfiguriert (hauptsächlich für mich als Merkzettel):

! Wir brauchen eine SSID
dot11 ssid mein_netzwerk
  ! Wir bauen das ganze hier im (AP internen) VLAN 8
  vlan 8
  authentication open
  ! Wir wollen WPA
  authentication key-management wpa
  ! Die SSID soll in den Beacons erscheinen
  guest-mode
  ! Unser Pre-Shared-Key ist "mein_schluessel"
  wpa-psk ascii mein_schluessel
interface Dot11Radio0
  ! Jetzt verkaufen wir der SSID die Verschlüsselung
  ! aes-ccm ist WPA2, tkip ist WPA

  encryption vlan 8 mode ciphers aes-ccm tkip
  ! Und die SSID müssen wir auch noch auf das Interface knoten
  ssid mein_netzwerk

! Und jetzt verheiraten wir das benötigte Subinterface mit dem Ethernetport, wir wollen ja bridgen
interface dot11Radio0.8
  ! Bitte alles untagged rauswerfen, hier gibts keine VLANs.
  encapsulation dot1q 8 native
  bridge-group 1

! Noch das FE in die Bridgegroup
interface FastEthernet0
  bridge-group 1

! Und dem Bridged Virtual Interface noch eine IP verpassen, damit wir auch managen können.
interface BVI1
  ip address 10.0.0.5
bridge 1 route ip


Fertig ist die Aironet Standalone Grundkonfiguration. Wer mag, kann noch Mac-Filtering oder dot1x gegen Radius einbauen.

Bitte nicht bei kleiner Flamme anbraten. So wie das hier.

March 04 2011

Ubuntu Netbook Remix und der Mac

Hier steht ein weißer eeepc 900A von guten Bekannten mit defekter Software. Da das installierte Xandros Murks ist, soll ein Ubuntu Netbook Remix auf die Kiste. Erstes Problem: Wie booten? In der Kramschublade liegt glücklicherweise noch ein größerer USB-Stick.

Also schnell (haha) das ISO runtergeladen, um es auf den Stick zu werfen. Bei Ubuntu gibts sogar eine Anleitung für den Mac. Die sieht soweit auch ganz sinnvoll aus: ISO mit hdiutil convert umbiegen, auf den Stick schreiben, fertig.

Denkste. Wenn man der Anleitung folgt, funktionierts erstmal nicht. Und ein bootbares USB Image wird auch nicht mehr angeboten.

Die Lösung:
VirtualBox runterladen, das UNR-ISO darin booten und mit dem Startup-Disk Creator von Ubuntu einen bootfähigen USB Stick erzeugen.

Kann denn nicht mal was so funktionieren, wie in der Anleitung beschrieben?

December 06 2010

OSPFv3 und EIGRPv6

Langeweile am Abend. Und was macht der gelangweilte Netzwerker: Klar, er konfiguriert mal OSPFv3 und EIGRP in einer IPv6-only Umgebung durch. Und dabei fällt auf: es ist angenehmer und schmerzfreier als mit IPv4.

GNS3 / Dynagen Config dafür:

autostart = False
[localhost:7200]
workingdir = /tmp
udp = 10000
[[2621XM]]
image = ...
ram = 128
idlepc = 0x8267a070
ghostios = True
chassis = 2621XM
[[ROUTER R1]]
model = 2621XM
console = 2005
f0/0 = R2 f0/0
f0/1 = R3 f0/0
[[ROUTER R2]]
model = 2621XM
console = 2007
f0/0 = R1 f0/0
f0/1 = R3 f0/1
[[ROUTER R3]]
model = 2621XM
console = 2008
f0/0 = R1 f0/1
f0/1 = R2 f0/1


Man nehme als 3 Router, die mit den FEs zusammengesteckt sind.

IPv6 Konfiguration






IP Adressen Routerfa0/0fa0/1 R12001:6f8:1101:2::1/642001:6f8:1101:3::1/64 R22001:6f8:1101:2::2/642001:6f8:1101:4::1/64 R32001:6f8:1101:3::2/642001:6f8:1101:4::2/64

Beispiel:

interface FastEthernet0/0
description link to R1
no ip address
duplex auto
speed auto
ipv6 address 2001:6F8:1101:3::2/64


Nicht vergessen: ipv6 unicast-routing aktivieren. Das ist wie auf Layer 3 Switchen ;-)

EIGRP

Früher hieß das ganze noch router eigrp AS, heute heißt das ganze ipv6 router eigrp AS. Was auffällt, ist dass der EIGRP per default im "SHUTDOWN" ist. Ein no shut im Routing Prozeß hilft dagegen.
Man sollte sich auch das passive-interface default angewöhnen. So muß man sich nicht mehr mit network Statements rumschlagen.

EIGRP Router Konfiguration

ipv6 router eigrp 1
router-id 3.3.3.3
no shutdown
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet0/1
redistribute connected


EIGRP sowie OSPFv3 brauchen immer noch eine Router-ID, die aussieht wie eine IPv4 Adresse. Mit no passive-interface werden die Interface ausgewählt, auf denen ein Routing Protokoll gesprochen werden soll.

Mit redistribute connected werden alle direkt angebundenen Netze verteilt.

So weit, so gut. Jetzt kommen aber noch keine neighbours hoch, sh ipv6 eigrp neigh zeigt noch nichts an. Die Interfaces müssen jetzt auch noch wissen, in welchem EIGRP AS sie sind.

interface FastEthernet0/0
ipv6 eigrp 1

kippt fa0/0 in das EIGRP AS 1. Wenn man das auf allen Routern tut, kommen auch die EIGRP Neighbours hoch. sh ip route ist in einer v6-only Umgebung ziemlich leer.

sh ipv6 route sieht dann etwa so aus:

R3#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
D 2001:6F8:1101:2::/64 [90/30720]
via FE80::CA05:3AFF:FEE1:1, FastEthernet0/0
via FE80::CA07:3AFF:FEE1:1, FastEthernet0/1
C 2001:6F8:1101:3::/64 [0/0]
via ::, FastEthernet0/0
L 2001:6F8:1101:3::2/128 [0/0]
via ::, FastEthernet0/0
C 2001:6F8:1101:4::/64 [0/0]
via ::, FastEthernet0/1
L 2001:6F8:1101:4::2/128 [0/0]
via ::, FastEthernet0/1
L FF00::/8 [0/0]
via ::, Null0


Also alles eigentlich ganz einfach :-)

OSPFv3

OSPFv3 ist auch nicht schwieriger. Auch hier heißt die Konfiguration wieder ipv6 router ospf PID.
OSPF beschwert sich im Gegensatz zu EIGRP auch mit %OSPFv3-4-NORTRID: OSPFv3 process 42 could not pick a router-id, please configure manually dass der Router keine v4 Adresse hat, aus der er sich eine Router-ID aussuchen kann.
Diese muß man händisch mit router-id 2.2.2.2 konfigurieren.

OSPFv3 Router Konfiguration:

ipv6 router ospf 42 router-id 1.1.1.1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
redistribute connected

Und auf dem Interface noch:

interface FastEthernet0/0
ipv6 ospf 42 area 0

Kein hantiere mehr mit Wildcard-Masks, komischen Network-Statements. Einfach das Interface einer Area und einem OSPF Prozeß zuordnen und schon funktionierts.
Wenn ich mal wieder einen ruhigen Abend habe, gibts was zu BGP und IPv6.


November 08 2010

Vorträge fürs Easterhegg 2011

Lange nichts mehr gebloggt.

Ich habe neulich[tm] mal ein paar Vorträge fürs Easterhegg 2011 eingereicht:


  • LVM - das unbekannte Wesen (Partitionen sind für Anfänger)

  • TCP/IP Basics (Wie geht das denn jetzt mit den Adressen?)

  • Eine kurze Geschichte des Internets (Was ist ein IMP und wofür braucht man BGP4?)



Mal schauen, was angenommen wird.

August 30 2010

August 28 2010

August 27 2010

August 26 2010

August 25 2010

August 24 2010

August 23 2010

Older posts are this way If this message doesn't go away, click anywhere on the page to continue loading posts.
Could not load more posts
Maybe Soup is currently being updated? I'll try again automatically in a few seconds...
Just a second, loading more posts...
You've reached the end.

Don't be the product, buy the product!

Schweinderl